3/29 Launch
Incident Report for Hype
Resolved
All platform updates have concluded.
Posted Mar 29, 2023 - 19:05 UTC
Monitoring
We are currently making updates to our platform. Users may experience a brief disruption in service.
Posted Mar 29, 2023 - 17:10 UTC