Platform Update
Incident Report for Hype
Resolved
All updates to our platform have concluded.
Posted Feb 21, 2023 - 23:33 UTC
Monitoring
We are currently deploying an update to our platform. Publishers may experience brief moments of downtime in the Pico web app. We will report when the update is complete.
Posted Feb 21, 2023 - 19:00 UTC